Texel TapeMetrix: Руководство пользователя
Краткое описание
Texel TapeMetrix - это программное обеспечение, автоматизирующее процесс цифровых обмеров тела человека по 3D-моделям. ПО совместимо как с фирменными 3D-сканерами Texel Portal, так и со сторонними технологиями - ручными 3D-сканерами, фотограмметрией и мобильными устройствами. TapeMetrix автоматически строит порядка 100 базовых параметров (обхваты, высоты, расстояния) по стандартам ГОСТ и ISO, и при этом вы всегда можете отредактировать полученные обмеры или добавить произвольные измерения в ручном режиме с помощью интуитивно понятного интерфейса. Обработка и хранение данных осуществляются полностью локально (доступ в интернет не требуется), таким образом обеспечивается полная конфиденциальность и безопасность.

Данное руководство описывает основной функционал Texel TapeMetrix и ключевые аспекты для эффективного использования данного ПО. Руководство содержит информацию об актуальной версии Texel TapeMetrix и дополняется по мере выхода новых версий и расширения функционала.
Ключевые понятия
-
3D-модель (или Полигональная модель) - это классическое представление 3D-данных в компьютерной графике в виде полигональной сетки - множества точек, соединённых полигонами (обычно, треугольниками). Такое представление является стандартным для приложений в области 3D-графики, 3D-сканирования и моделирования. К популярным форматам файлов для хранения 3D-моделей относятся OBJ, PLY, STL, FBX, glTF и другие. Texel TapeMetrix поддерживает импорт широкого набора форматов, что обеспечивает совместимость со сторонним программным обеспечением.
-
Проект - это способ хранения 3D-модели тела и обмеров, а также дополнительной информации. Проекты Texel TapeMetrix имеют расширение ".txm", и их можно сохранять на диск, загружать, пересылать по электронной почте и другим каналам связи. Файлы с расширением ".txm" гарантированно откроются более новой версией Texel TapeMetrix (обратная совместимость); прямая совместимость обычно сохраняется, но не гарантируется.
-
Ключевая точка - это точка на поверхности 3D-модели тела, через которую должен проходить обмер. Ключевые точки в Texel TapeMetrix можно создавать (автоматически и вручную), удалять и перемещать. Ключевые точки соединяются одним из четырех видов пути, каждый из которых имеет своё цветовое обозначение как при визуализации на модели, так и в иконках на панели инструментов.
-
Путь - это способ соединения двух ключевых точек. Texel TapeMetrix поддерживает 4 вида путей:
- Лента моделирует поведение портновской ленты, проходящей поверх впадин на поверхности тела (например, при измерении обхвата груди).
- Контур соединяет точки, проходя по кратчайшему пути строго по поверхности тела (геодезический путь). Применяется для контурных обхватов.
- Расстояние соединяет точки по прямой, может проходить сквозь 3D-модель.
- Высота измеряет высоту между двумя ключевыми точками.
-
Обмер - это совокупность ключевых точек, соединенных с помощью путей. Один обмер может содержать различные пути, а также быть замкнутым (например, обхват) или незамкнутым (например, ширина груди). Числовое значение обмера складывается из длин составляющих его путей, при этом поддерживаются различные единицы измерения.
Интерфейс пользователя

Основное окно Texel TapeMetrix состоит из следующих элементов:
-
Строка меню, содержащая пункты Файл, Правка, Вид, Инструменты и Помощь. Из меню доступны все функции приложения, при этом наиболее часто используемые действия имеют горячие клавиши.
-
Панели инструментов, содержащие кнопки с иконками для наиболее часто используемых функций. Панели инструментов можно скрывать и перетаскивать в удобное место окна.
-
Боковые панели с основным функционалом (Обмеры и Информация о проекте). Эти панели выполнены в стиле док-виджетов, то есть могут быть расположены в любом месте основного окна, и, в том числе, откреплены от него. При желании можно скрывать неиспользуемые панели (управлять видимость панелей можно через меню Вид. Для того, чтобы вернуть компоновку окна в изначальное состояние, можно использовать пункт меню Вид > Сбросить компоновку окна.
-
Основная рабочая область окна служит для отображения 3D-модели и действий с обмерами (например, добавление или удаление ключевых точек).
Изменить язык интерфейса и тему оформления можно в Настройках (меню Файл > Настройки...).
Создание нового проекта
Для создания нового проекта необходимо нажать на кнопку Новый проект... на начальном экране, либо выбрать пункт меню Файл > Новый... (либо соответсвующую кнопку на основной панели инструментов). Также можно использовать сочетания клавиш Ctrl+N.
При создании нового проекта откроется диалог открытия файла 3D-модели для импорта в проект. Основные требования к загружаемым 3D-моделям:
- Поддерживаемые форматы файлов: OBJ, GLB, glTF, COLLADA (DAE), FBX, X3D, STL, 3MF, PLY
- Модель может быть без цвета, либо с текстурой (в формате JPEG или PNG)
- Рекомендуемое количество треугольников: от 50,000 до 150,000
- Проддерживаемые единицы измерения: миллиметры, сантиметры, метры, дюймы, футы (поддерживается автоматическое определение)
- Вертикальная ось: Y или Z (поддерживается автоматическое определение)
- Для работы автоматических обмеров 3D-модель должна быть в А-позе (ноги на ширине плеч, руки симметрично располагаются под углом в 30-45 градусов к телу) и в обтягивающей одежде (либо в нижнем белье)
- Модель может содержать небольшие артефакты геометрии, присущие 3D-сканированию, однако, в случае серьезных проблем с топологией загрузка модели может завершиться неудачей
После выбора файла и успешной загрузки 3D-модели будет показан следующий диалог:

Единицы измерения и ориентация модели определяются автоматически, при этом в случае некорректного определения можно внести необходимые изменения. Также на данном этапе можно указать дополнительную информацию о проекте. Рекомендуется сразу указать пол человека (Мужской или Женский). Для продолжения необходимо нажать кнопку OK в нижней части диалога.
Добавление автоматических обмеров в проект
После успешного создания нового проекта на основе выбранной 3D-модели будет предложено добавить в проект автоматические обмеры в качестве стартовых (также добавить дополнительные автоматические обмеры можно будет в любой момент):

Выберите желаемые обмеры из списка поддерживаемых (отметьте их галочками). Для быстрого поиска используйте поле Фильтр обмеров сразу над списком, а для быстрого выбора - кнопки под списком: Выбрать (позволяет выбирать часто используемые наборы обмеров), Выбрать все и Очистить выбор.
Выпадающий список Именование обмеров позволяет задать схему именования: Только названия, идентификаторы по стандарту ISO 8559-1, либо идентификаторы по стандартам ГОСТ 31396 / 31399.
После выбора желаемых автоматических обмеров нажмите кнопку OK в нижней части диалога. Если добавление автоматических обмеров не требуется - нажмите кнопку Отмена. Добавить автоматические обмеры можно будет в любой момент с помощью меню Инструменты > Автоматические обмеры..., либо соответствующей кнопки на панели инструментов. Также можно использовать сочетание клавиш Ctrl+M.
Управление обмерами
Для просмотра и управления обмерами служит панель Обмеры (по умолчанию расположена в левой части окна), содержащая таблицу со всеми обмерами тела в текущем проекте. Если панель не отображается, то можно включить её видимость в меню Вид > Обмеры (или использовать сочетание клавиш Ctrl+Shift+M).

Для быстрого поиска обмеров используйте поле Фильтр обмеров над таблицей. Нажимая на заголовки столбцов таблицы, можно менять сортировку, а нажатие на иконку в левом столбце закрепляет обмер наверху таблицы (также он будет всегда отображаться на 3D-модели, даже если активен другой обмер).
При нажатии левой кнопкой мыши на названии обмера он становится выделенным (активным) и переходит в режим редактирования (можно менять положение ключевых точек, добавлять или удалять их). Для переименования обмера дважды щелкните на его названии левой кнопкой мыши, либо выделите его и нажмите клавишу F2. Для удаления выделенного обмера нажмите клавишу Del. Также все действия над обмерами доступны из контекстного меню, для вызова которого необходимо щелкнуть правой кнопкой мыши на нужном обмере.
Навигация в 3D и управление отображением
В процессе работы с обмерами на 3D-модели можно поворачивать, приближать и перемещать виртуальную камеру:
-
Перемещайте мышь с зажатой левой кнопкой для поворота. Если используется тачпад ноутбука, то перемещайте палец по тачпаду, одновременно нажимая на него.
-
Используйте колесико мыши для приближения или отдаления. На тачпаде можно использовать жест приближения (прикоснитесь к тачпаду большим и указательным пальцами и разводите их дальше друг от друга, для отдаления - наоборот, сводите их ближе).
-
Перемещайте мышь с зажатым колесиком (средней кнопкой мыши), чтобы двигать вирутальную камеру. На тачпаде ноутбука можно перемещать палец по тачпаду, одновременно нажимая на него и при этом зажимая клавишу Shift другой рукой.
-
Для сброса положения виртуальной камеры можно использовать кнопку Сбросить камеру на панели инструментов, меню Вид > Сбросить камеру, либо нажать клавишу Home на клавиатуре.
-
Для быстрого переключения видов с разных сторон используйте соответствующие кнопки на панели инструментов, пункты в меню Вид, либо горячие клавиши 1 - 6.
Для удобства работы предусмотрены также различные режимы отображения 3D-модели:
-
Кнопка Показывать текстуру на панели инструментов (либо пункт меню Вид > Показывать текстуру, горячая клавиша X) позволяет включать и выключать отображение текстуры 3D-модели.
-
Кнопка Освещение на панели инструментов (либо пункт меню Вид > Освещение, горячая клавиша L) позволяет включать и выключать источник света.
-
Кнопка Гладкое затенение на панели инструментов (либо пункт меню Вид > Гладкое затенение, горячая клавиша S) переключает режимы затенения (гладкое или по граням).
-
Кнопка Показывать сетку на панели инструментов (либо пункт меню Вид > Показывать сетку, горячая клавиша W) включает отображение сетки.
-
Кнопка Ортографическая проекция на панели инструментов (либо пункт меню Вид > Ортографическая проекция, горячая клавиша O) переключает перспективную и ортографическую проекции. Ортографическая проекция - это способ изображения трехмерных объектов на плоскости, при котором проецирующие лучи падают на плоскость проекции строго перпендикулярно. Главное преимущество ортографической проекции - это полное отсутствие перспективных искажений, что позволяет сохранять точные пропорции и размеры объекта.
Создание нового обмера
Чтобы создать новый обмер, воспользуйтесь кнопкой Новый обмер на панели инструментов, меню Инструменты > Новый обмер либо используйте горячую клавишу M. После задания имени нового обмера нажмите клавишу Enter.
Texel TapeMetrix поддерживает несколько инструментов для задания геометрии обмеров:
Задание обмера по ключевым точкам
Выберите инструмент Ключевая точка на панели инструментов (либо в меню Инструменты > Ключевая точка, горячая клавиша K) и нажмите левой кнопкой мыши на любое место на поверхности 3D-модели - будет создана первая ключевая точка обмера. Затем нажмите в другом месте на поверхности 3D-модели - будет создана вторая ключевая точка, соединенная с первой с помощью текущего выбранного пути (на панели инструментов, либо в меню Инструменты). Пути разных типов обозначаются соответствующими цветами как в иконках и курсорах, так и на 3D-модели:

- Лента (Инструменты > Лента, клавиша T) моделирует поведение портновской ленты, проходящей поверх впадин на поверхности тела (например, при измерении обхвата груди).
- Контур (Инструменты > Контур, клавиша С) соединяет точки, проходя по кратчайшему пути строго по поверхности тела (геодезический путь). Применяется для контурных обхватов.
- Расстояние (Инструменты > Расстояние, клавиша D) соединяет точки по прямой, может проходить сквозь 3D-модель.
- Высота (Инструменты > Высота, клавиша H) измеряет высоту между двумя ключевыми точками.

Ключевые точки обозначаются фиолетовыми сферами, активная точка отмечена красным цветом, а активный путь (от предыдущей точки до выбранной) - зелёным. Начальная и конечная точки обмера обозначены сферами чуть большего размера. Для выбора активной точки щелкните по ней левой кнопкой мыши, для корректировки её положения - перетащите её мышью на новое место. Для удаления выбранной точки нажмите клавишу Del, либо выберите пункт Удалить точку из контекстного меню, доступного при нажатии правой кнопкой мыши:

Кроме того, контекстное меню позволяет добавить новую точку между активной и предыдущей точкой (клавиша I) и изменить тип пути между ключевыми точками.
Для создания замкнутого обмера (например, обхвата) переместите конечную точку близко к начальной (или сразу создайте новую точку рядом с начальной), чтобы автоматически их совместить.
Создание горизонтального обхвата
Для быстрого создания горизонтального обхвата (строго параллельно полу), выберите инструмент Горизонтальный обхват на панели инструментов (либо в меню Инструменты > Горизонтальный обхват, горячая клавиша G), а затем нажмите в любом месте на поверхности 3D-модели. В результате этого будет автоматически построен горизонтальный обхват, проходящий через указанную точку поверхности:

Создание обхвата конечности
В ряде случаев требуется, чтобы плоскость обхвата проходила перпендикулярно оси (например, при создании обхватов конечностей). Для автоматического создания такого обхвата выберите инструмент Обхват конечности на панели инструментов (либо в меню Инструменты > Обхват конечности, горячая клавиша B), а затем нажмите в любом месте на поверхности 3D-модели. Через указанную точку поверхности будет построен обхват, ориентированный перпендикулярно к локальной оси:

Работа с проектами
Во время работы над проектом каждое действие (например, удаление обмера, изменение ключевых точек и т.д.) можно отменить, если оно ошибочно. Для того, чтобы отменить предыдущее действие, используйте кнопку Отменить на панели инструментов, пункт меню Правка > Отменить, либо сочетание клавиш Ctrl+Z. Чтобы повторить отмененное действие, используйте кнопку Повторить на панели инструментов, пункт меню Правка > Повторить, либо сочетание клавиш Ctrl+Y.
Texel TapeMetrix использует собственный формат файлов проектов - это файлы с расширением ".txm", содержащие как 3D-модель тела и все созданные обмеры, так и дополнительную информацию (например, пол человека, возраст, вес, имя, дополнительные комментарии). Дополнительную информацию можно изменить, выбрав пунки меню Файл > Свойства проекта..., либо использовать кнопку на панели Информация о проекте:

Открыть проект можно дважды щелкнув на нем в файловом менеджере, либо выбрав кнопку Открыть на панели инструментов (либо пункт меню Файл > Открыть..., либо сочетание клавиш Ctrl+O). Для сохранения проекта на диск используйте кнопку Сохранить на панели инструментов (либо пункт меню Файл > Сохранить, либо сочетание клавиш Ctrl+S). Для того, чтобы сохранить проект в новый файл, используйте кнопку Сохранить как... или соотстветсвующий пункт меню.
Файлы с расширением ".txm" гарантированно откроются более новой версией Texel TapeMetrix (обратная совместимость); прямая совместимость обычно сохраняется, но не гарантируется. Проекты можно не только хранить на диске, но и использовать для обмена информацией (например, по электронной почте), если у получателя также установлено ПО Texel TapeMetrix.
Экспорт данных
Texel TapeMetrix поддерживает экспорт обмеров в форматы Microsoft Excel (XLSX) и CSV. При этом для экспорта в Microsoft Excel доступны дополнительные возможности, такие как визуализация каждого обмера (генерация изображений) и экспорт информации о проекте на отдельном листе. В CSV экспортируются только обмеры (названия и значения) в силу ограничений формата.
Для экспорта данных используйте кнопку Экспорт на панели инструментов (либо пункт меню Файл > Экспорт..., либо сочетание клавиш Ctrl+E). При выборе формата Microsoft Excel будет дополнительно открыт диалог параметров экспорта:

После нажатия кнопки OK будет создан файл Microsoft Excel с выбранными опциями:

Изменение настроек
Используйте пункт меню Файл > Настройки... для изменения настроек приложения, таких как язык и тема интерфейса, а также единицы измерения для обмеров и веса:

Для сохранения выбранных настроек нажмите кнопку OK в нижней части диалога.